human00731582 wrote:Is there a standard -- something akin to the variable-naming convention of szString, iInteger, cChar, and so on...
...which is utter donkey manure.
What you are referring to is called "System Hungarian", and it is what happens when mediocre coders hear of a principle sound
in a different environment, misunderstand it, misapply it, and generally make a mockery of it.
If you are coding clean C, the type definition of your variable is quite close to hand:
Code: Select all
int number;
// if your code goes on for more than one, max two screen
// heights before 'number' goes out of scope, chances are your
// function is doing too much and should be refactored.
So what does adding a "type wart" do?
It duplicates information that is already there, and obfuscates another bit of information (what the actual variable is about, "number"). It
also makes communication more difficult, because you will either stumble your tongue over the type warts (only one or two characters, but usually just as many syllables), or omit them, and thus lose precision of meaning.
When Hungarian Notation was
introduced by Charles Simonyi, it was about adding information that is
not there already:
rwNumber is a ROW number. xwPos is the x position relative to the window, and ywPos is the y position relative to the window. All ints. None of them interchangeable.
Unfortunately, Simonyi talked about "type" of variable, not "kind" of variable (which is what he
meant) when he presented his paper, and when the idea spread beyond the team Simonyi worked in (the "apps" team), people took "type" literally, and "Apps Hungarian" became "System Hungarian", the crap idea of prefixing every integer with "i" and every string with "sz" and so generally making a mess of readability with information that is redundant if you're lucky, and inconsistent if you're not, but serves no practical purpose other than making identifiers longer, and harder to read / talk about.
Or, to quote from
How to write unmaintainable code: "Hungarian Notation is the tactical nuclear weapon of source code obfuscation techniques."
Apps Hungarian can serve a purpose in dynamically typed languages, is borderline useless in typed languages, and a complete nuisance in strongly-typed OO languages like C++. Don't infect yet another code base with it, even Microsoft have deprecated the idiom years ago (
both System
and Apps Hungarian)...
---
Now to find the two chaps who couldn't decide whether every C++ class should be prefixed with "C" for "class" or "T" for "type" and made the code base I am working with such a
fun experience...